[Frugalware-devel] pacman 3.3.4

VMiklos vmiklos at frugalware.org
Mon Aug 7 12:02:01 CEST 2006


On Mon, Aug 07, 2006 at 07:46:49PM +1000, Cameron Daniel <me at camdaniel.com> wrote:
> The error seems to a non-programmer to be libarchive related and I've
> checked and neither Frugalware or Arch seem to have anything
> special in the libarchive package. Any suggestions would be appreciated.

yes, but Frugalware's libarchive has no 'acl' support, while Arch's one
has. as long as you don't build in chroot (they don't) you can't disable
acl support, while depending on acl from pacman is unnecessary and
uncomfortable.

so:

1) try LDFLAGS="-lacl" ./configure, probably it will solve you problem
(but it will cause an extra dependency)

2) we should add a configure check for this. i'll try to prepare a patch
for this, then you can test it if you want

udv / greetings,
VMiklos

-- 
Developer of Frugalware Linux, to make things frugal - http://frugalware.org


More information about the Frugalware-devel mailing list