[Frugalware-devel] I need help fixing Frugalbuilds

Russell Dickenson russelldickenson at gmail.com
Sat May 30 15:25:30 CEST 2009


On Sat, May 30, 2009 at 11:16 PM, Miklos Vajna <vmiklos at frugalware.org> wrote:
> On Fri, May 29, 2009 at 03:27:17PM +1000, Russell Dickenson <russelldickenson at gmail.com> wrote:
>> UNRAR
>> This looked to be quite an easy one but I am confused after doing a
>> little research.  The version packaged in "current" is 3.8.5 but the
>> home page reports that the latest stable version is 3.8.0, and the
>> very latest - beta - version is 3.9.3.  I believe FW's policy is to
>> package only stable versions, unless there's no other choice - e.g.
>> there's a critical bug with the beta version.  I have no idea what
>> version to which unrar should be upgraded.  If we stick only to stable
>> versions, in fact this should be downgraded.
>
> Yep, that's pretty confusing. http://www.rarlab.com/rar_add.htm just
> lists 3.9.3 as "UnRAR source", so I considered it a safe operation to
> just update.
>
>> JAM
>> This is one that perhaps I should avoid, but when I go looking for the
>> Frugalbuild via the "git" link on the Frugalware package's details
>> page, git's web interface says that it doesn't exist.
>
> It has been moved to devel-extra from devel without incrementing the
> pkgrel, that's why the website still refers to devel. If you edit the
> link, you'll get it.
>
> And yes, its up2date is broken, you could use something like:
>
> lynx -dump http://public.perforce.com/wiki/Jam|grep stable|sed 's/.* rev \([^ ]*\) .*/\1/'
>
> No, I did not pushed it, feel free to do so. :)
>
>> LINPOPUP
>> As a starting point with updating or correcting packages which fail
>> the 'chkworld' test, I went looking for LINPOPUP's up2date line but it
>> seems that it doesn't have one.  Is it that this package was created
>> before anyone had the idea for the up2date line?
>
> You just need this:
>
> diff --git a/source/network-extra/linpopup/FrugalBuild b/source/network-extra/linpopup/FrugalBuild
> index 447408b..5523fda 100644
> --- a/source/network-extra/linpopup/FrugalBuild
> +++ b/source/network-extra/linpopup/FrugalBuild
> @@ -10,6 +10,7 @@ rodepends=('samba-client')
>  groups=('network-extra')
>  archs=('i686' 'x86_64')
>  _F_sourceforge_dirname="linpopup2"
> +_F_sourceforge_realname="LinPopUp-2"
>  Finclude sourceforge
>  url="http://linpopup2.sourceforge.net/"
>
> Again, I did not push this, I'll leave it to you for practicing. :)
>
> In general, if you can fix an up2date where the current result is
> obviously wrong, feel free to push it without asking, just make sure do
> not break the source() or $url variables. :)
>
> (Edit the FB, run chkworld, if it has a reasonable output, then run
> makepkg -dgu, and if it can still download the source, you can
> commit&push it.)

Thanks for your advice.  I'll try out the two you've given solutions
for and see what result I get.


May you always be Frugal,

Russell Dickenson (AKA phayz)


More information about the Frugalware-devel mailing list