[Frugalware-devel] [New package] Clementine

bouleetbil (gaetan) bouleetbil at frogdev.info
Wed Aug 25 11:52:31 CEST 2010


Le Tue, 24 Aug 2010 14:56:46 +0200,
Antoine Chevaux <achevaux at gmail.com> a écrit :

> Hi,
> I've made this FrugalBuild for Clementine player: It's a port of Amarok 1.4,
> if you're nostalgic ;) .
> Here it is:
> 
> # Compiling Time: 0.63 SBU
> # Contributor: centuri0 <achevaux @ gmail dot com>
> pkgname=clementine
> pkgver=0.4.2
> pkgrel=1
> pkgdesc="Clementine is a modern music player and library organiser. Port of
> Amarok 1.4"
> makedepends=('boost')
> depends=('qt4' 'glew' 'liblastfm' 'taglib' 'gstreamer')
> _F_googlecode_dirname="
> clementine-player"
> _F_cd_path="$pkgname-$pkgver"
> Finclude googlecode cmake
> groups=(apps-extra)
> archs=('i686' 'x86_64')
> sha1sums=('5bbec64089226d7ebf1719fe693990407a3b5a59')
> # optimization OK
> 
> Builds, and works fine but when I try to install it, pacman doesn't want to
> install glew as depend. I have to install it before, then install
> clementine. see below:
> http://frugalware-fr.pastebin.com/idwDMzku
> So how come?
> 
> Thanks
> Centuri0

hi,
qt4 is a meta package try makepkg -a for find the real depends
by

-- 
#--------------------------------------------------------------------------- 
#                            Bouleetbil
#
#---------------------------------------------------------------------------  
#             _    _
#            (o)--(o)
#           /.______.\
#           \________/
#          ./        \.
#         ( .        , )
#          \ \_\\//_/ /
#           ~~  ~~  ~~
#--------------------------------------------------------------------------- 


More information about the Frugalware-devel mailing list