[Frugalware-devel] Akonadi database switch

bouleetbil (gaetan) bouleetbil at frogdev.info
Sun Apr 24 21:47:38 CEST 2011


Le Sun, 24 Apr 2011 21:30:52 +0200,
Miklos Vajna <vmiklos at frugalware.org> a écrit :

> On Sun, Apr 24, 2011 at 09:53:40PM +0300, Marius Cirsta <mforce2 at gmail.com> wrote:
> > Every time KDE 4 started I got a kres-migrator start which runs before
> > Akonadi does. It turns out kres-migrator wasn't able to run because
> > Akonadi no longer supports sqlite as a database. The default is now
> > mysql and postgresql is an alternative ( doesn't seem that well
> > maintained however ).
> > 
> > Attached are two patches for adding dependencies needed because of
> > this switch to mysql for both current and stable. Also for current
> > there's a version bump to 1.5.2.
> 
> Hi,
> 
> Hmm, but this will break our "main vs extra" policy, since akonadi is
> installed by default, while mysql is not.
> 
> Michel, isn't it possible to fix sqlite-default.patch?

Hi,
I don't if that can help but stable frugalware use sqlite : http://git.frugalware.org/gitweb/gitweb.cgi?p=frugalware-stable.git;a=blob;f=source/xapps/akonadi/sqlite-default.patch;h=f70bf2cdd267da5c328040eaa57aa246e915f724;hb=HEAD


More information about the Frugalware-devel mailing list