[Frugalware-git] kernel2634: mesa-7.8.1-1-i686

Michel Hermier hermier at frugalware.org
Tue May 18 14:17:14 CEST 2010


Git-Url: http://git.frugalware.org/gitweb/gitweb.cgi?p=kernel2634.git;a=commitdiff;h=63e1c50fd4a7e01300de826172b97669b29ddfdd

commit 63e1c50fd4a7e01300de826172b97669b29ddfdd
Author: Michel Hermier <hermier at frugalware.org>
Date:   Tue May 18 14:16:50 2010 +0200

mesa-7.8.1-1-i686

* Bump version.

diff --git a/source/x11/mesa/FrugalBuild b/source/x11/mesa/FrugalBuild
index 8dea3a6..d3cb103 100644
--- a/source/x11/mesa/FrugalBuild
+++ b/source/x11/mesa/FrugalBuild
@@ -8,7 +8,7 @@ USE_GALLIUM=${USE_GALLIUM:-"y"}
pkgname=mesa
origname=Mesa
_F_archive_name="MesaLib"
-pkgver=7.7.1
+pkgver=7.8.1
pkgrel=1
pkgdesc="Mesa is a 3D graphics library"
url="http://mesa3d.sourceforge.net/"
@@ -31,8 +31,8 @@ if Fuse $USE_DEVEL; then
else
source=("ftp://ftp.freedesktop.org/pub/mesa/$pkgver/MesaLib-$pkgver.tar.bz2" \
"ftp://ftp.freedesktop.org/pub/mesa/$pkgver/MesaDemos-$pkgver.tar.bz2")
-	sha1sums=('31500d7e3e3bbf9288b3bee4fbddd26a5e0b7782' \
-		'32cb484bf0963e58f47bdfe16f127e4195f1f7ad')
+	sha1sums=('1c15c62f845ef9b648366aa804410f68f7f79172' \
+		'42618c17fb7be6d96ef73ff007e41aac5d3ded65')
fi

source=("${source[@]}" \
@@ -48,7 +48,7 @@ subdescs=('Mesa DRI OpenGL files.' 'Mesa OpenGL headers files.')
subprovides=('libgl-mesa libgl-mesa-dri libgl-mesa-soft' 'libgl-headers')
subreplaces=('libgl-mesa-soft' 'libgl-headers') # Remove libgl-headers after 1.1
subconflicts=('fglrx libgl-mesa-soft nvidia' 'nvidia')
-subdepends=('libdrm>=2.4.17 libxcb>=1.3 libxdamage>=1.1.1-3 libxxf86vm>=1.0.2' '')
+subdepends=('libdrm>=2.4.20 libxcb>=1.3 libxdamage>=1.1.1-3 libxxf86vm>=1.0.2' '')
subrodepends=("libdri libgl-headers-mesa>=$pkgver-$pkgrel libglx" '')
subgroups=('x11' 'x11')
subarchs=('i686 x86_64 ppc' 'i686 x86_64 ppc')
@@ -130,7 +130,7 @@ build() {
# Install our .la files with r-xr-xr-x rights
Finstall 0555 lib{GL,GLU}.la /usr/lib/

-	Fln libGLU.so.1.3.070701 /usr/lib/libGLU.so.1.3
+	Fln libGLU.so.1.3.070801 /usr/lib/libGLU.so.1.3
Fln libGLw.so.1.0.0 /usr/lib/libGLw.so.1.0

# Remove glut.h because it conflicts with freeglut :P


More information about the Frugalware-git mailing list