[Frugalware-git] gnometesting: empathy-2.91.91-2-x86_64 *rebuild with folks 0.4.0 *enable networkmanager support *use git version (they will release a new version) *too lazy to backport patchs for some days :D *only gnome-applets(deprecated) rhytmbox and empathy use git version

bouleetbil bouleetbil at frogdev.info
Wed Mar 16 09:46:28 CET 2011


Git-Url: http://git.frugalware.org/gitweb/gitweb.cgi?p=gnometesting.git;a=commitdiff;h=38bee49642618ee8a99a666d83efd219999c1ce6

commit 38bee49642618ee8a99a666d83efd219999c1ce6
Author: bouleetbil <bouleetbil at frogdev.info>
Date:   Wed Mar 16 09:44:49 2011 +0100

empathy-2.91.91-2-x86_64
*rebuild with folks 0.4.0
*enable networkmanager support
*use git version (they will release a new version)
*too lazy to backport patchs for some days :D
*only gnome-applets(deprecated) rhytmbox and empathy use git version

diff --git a/source/gnome/empathy/FrugalBuild b/source/gnome/empathy/FrugalBuild
index 404e9de..7868fcd 100644
--- a/source/gnome/empathy/FrugalBuild
+++ b/source/gnome/empathy/FrugalBuild
@@ -8,18 +8,18 @@ USE_SENDTO=${USE_SENDTO:-"n"}

pkgname=empathy
pkgver=2.91.91
-pkgrel=1
+pkgrel=2
pkgdesc="Empathy consists of a rich set of reusable instant messaging widgets"
depends=('telepathy-glib' 'libxml2' 'enchant' 'ca-certificates' \
-	'libglade' 'atk' 'pango' 'freetype2' 'libxau' 'libxdmcp' 'e2fsprogs' \
+	'atk' 'pango' 'freetype2' 'libxau' 'libxdmcp' 'e2fsprogs' \
'popt' 'nspr' 'openssl>=1.0.0' 'libxdamage' 'libxinerama' \
'libxi' 'libxrandr' 'libxcursor' 'libjpeg>=8a' \
'libsm' 'libffi' 'telepathy-stream-engine' \
'aspell' 'iso-codes' 'telepathy-mission-control' 'telepathy-gabble' \
'evolution-data-server>=2.90.0' 'libcanberra-gtk' 'telepathy-farsight' \
-	'webkit-gtk3' 'unique' 'libkrb5' 'folks>=0.2.1' 'telepathy-logger' \
+	'webkit-gtk3' 'unique' 'libkrb5' 'folks>=0.4.0' 'telepathy-logger' \
'ca-certificates' 'gsettings-desktop-schemas' 'libnotify>=0.7' 'telepathy-butterfly' \
-	'telepathy-logger')
+	'telepathy-logger' 'networkmanager')
makedepends=('gnome-common' 'intltool' 'gtk-doc' 'gnome-doc-utils' 'krb5')
groups=('gnome')
archs=('i686' 'x86_64' 'ppc')
@@ -27,6 +27,7 @@ options=('scriptlet')
_F_gnome_iconcache="y"
_F_gnome_desktop="y"
_F_gnome_glib="y"
+_F_gnome_git="y"
Finclude gnome gnome-scriptlet
Fconfopts="${Fconfopts[@]} --enable-python=yes --enable-gtk-doc \
--disable-scrollkeeper --enable-spell=yes \
@@ -51,7 +52,16 @@ else
replaces=("${replaces[@]}" "$pkgname-nautilus-sendto")
fi

+if [ "$_F_gnome_git" != "n" ]; then
+	unset sha1sums
+fi
+
build() {
+	if [ "$_F_gnome_git" != "n" ]; then
+		Funpack_scm
+		Fcd $pkgname
+		sh ./autogen.sh
+	fi
Fbuild
Fbuild_gnome_scriptlet
if Fuse $USE_SENDTO; then


More information about the Frugalware-git mailing list