[Frugalware-git] gnometesting: unity-2d-3.8.1-1-i686 * new package

Devil505 devil505linux at gmail.com
Wed Mar 30 15:20:08 CEST 2011


Git-Url: http://git.frugalware.org/gitweb/gitweb.cgi?p=gnometesting.git;a=commitdiff;h=cf0c8feac7714c21f580ce0f72d0e3c8ac0bb365

commit cf0c8feac7714c21f580ce0f72d0e3c8ac0bb365
Author: Devil505 <devil505linux at gmail.com>
Date:   Wed Mar 30 15:19:39 2011 +0200

unity-2d-3.8.1-1-i686
* new package

diff --git a/source/ayatana-extra/unity-2d/FrugalBuild b/source/ayatana-extra/unity-2d/FrugalBuild
new file mode 100644
index 0000000..0c1406a
--- /dev/null
+++ b/source/ayatana-extra/unity-2d/FrugalBuild
@@ -0,0 +1,21 @@
+# Compiling Time: 0.12 SBU
+# Maintainer: Devil505 <devil505linux at gmail.com>
+
+pkgname=unity-2d
+pkgver=3.8.1
+pkgrel=1
+pkgdesc="unity-2d project is a 2d implementation of Unity"
+depends=('libwnck2' 'libdbusmenu-qt' 'libindicator' 'libqtbamf' 'libqtdee' 'libqtgconf' \
+    'utouch-geis' 'unity-asset-pool')
+groups=('ayatana-extra')
+archs=('i686' 'x86_64')
+Finclude cmake launchpad
+Fpkgversep="_"
+up2date="Flasttar https://launchpad.net/ubuntu/natty/+source/$pkgname | sed 's/.orig//g'"
+source=(https://launchpad.net/ubuntu/natty/+source/$pkgname/$pkgver-0ubuntu1/+files/$pkgname$Fpkgversep$pkgver.orig.tar.gz \
+	gio-unix.patch)
+_F_cd_path="$pkgname-$pkgver"
+sha1sums=('7412af9936e613b3c5c11545acdf41fbdfee6a8e' \
+          'd959d8c83da295699757c953a58630bf895061f5')
+
+# optimization OK
diff --git a/source/ayatana-extra/unity-2d/gio-unix.patch b/source/ayatana-extra/unity-2d/gio-unix.patch
new file mode 100644
index 0000000..6f4365f
--- /dev/null
+++ b/source/ayatana-extra/unity-2d/gio-unix.patch
@@ -0,0 +1,26 @@
+--- unity-2d-0.1/launcher/UnityApplications/CMakeLists.txt.orig	2011-01-14 19:40:10.000000000 +0100
++++ unity-2d-0.1/launcher/UnityApplications/CMakeLists.txt	2011-01-19 12:39:14.085966085 +0100
+@@ -4,6 +4,7 @@
+ pkg_check_modules(QTDEE REQUIRED libqtdee)
+ pkg_check_modules(GDK REQUIRED gdk-2.0)
+ pkg_check_modules(GIO REQUIRED gio-2.0)
++pkg_check_modules(GIO_UNIX REQUIRED gio-unix-2.0)
+ pkg_check_modules(WNCK REQUIRED libwnck-1.0)
+
+ # Sources
+@@ -57,6 +58,7 @@
+     ${QTDEE_INCLUDE_DIRS}
+     ${GDK_INCLUDE_DIRS}
+     ${GIO_INCLUDE_DIRS}
++    ${GIO_UNIX_INCLUDE_DIRS}
+     ${WNCK_INCLUDE_DIRS}
+     )
+
+@@ -69,6 +71,7 @@
+     ${QTDEE_LDFLAGS}
+     ${GDK_LDFLAGS}
+     ${GIO_LDFLAGS}
++    ${GIO_UNIX_LDFLAGS}
+     ${WNCK_LDFLAGS}
+     )
+


More information about the Frugalware-git mailing list