[Frugalware-security] [ FSA-87 ] phpbb

voroskoi noreply at frugalware.org
Thu Jan 11 18:15:32 CET 2007


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Frugalware Security Advisory                           FSA-87

Date: 2007-01-11
Package: phpbb
Vulnerable versions: <= 2.0.21-1
Unaffected versions: >= 2.0.22-1siwenna1
Related bugreport: http://bugs.frugalware.org/task/1515
CVE: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-6421
			http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-6508
			http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-6841

Description
===========

Some vulnerabilities have been discovered in phpBB, which can be exploited by malicious people to conduct cross-site request forgery attacks and cross-site scripting attacks.
1) The application allows users to send messages via HTTP requests without performing any validity checks to verify the request. This can be exploited to send messages to arbitrary users by e.g. tricking a target user into visiting a malicious website.
2) Input passed to the form field &quot;Message body&quot; in privmsg.php is not properly sanitised before it is returned to the user when sending messages to a non-existent user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.
Successful exploitation of the vulnerabilities requires that the target user is logged in.

Updated Packages
================

Check if you have phpbb installed:

	# pacman -Q phpbb

If found, then you should upgrade to the latest version:

	# pacman -Sy phpbb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)
Comment: See http://ftp.frugalware.org/pub/README.GPG for info

iD8DBQFFpnC0Z7NElSD1VhkRAjgGAJ9twg7bufs/+GW/er5VrjTVkKBxwwCdH8o2
h9x9XpIIl5Jb6qqdtXpdu0M=
=4QpJ
-----END PGP SIGNATURE-----


More information about the Frugalware-security mailing list