[Frugalware-security] [ FSA-301 ] madwifi

voroskoi noreply at frugalware.org
Tue Oct 23 09:19:11 CEST 2007


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Frugalware Security Advisory                           FSA-301

Date: 2007-10-23
Package: madwifi
Vulnerable versions: <= 0.9.3.2-4
Unaffected versions: >= 0.9.3.3-1sayshell1
Related bugreport: http://bugs.frugalware.org/task/2495
CVE: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-5448

Description
===========

Clemens Kolbitsch and Sylvester Keil have reported a vulnerability in MadWifi, which can be exploited by malicious people to cause a DoS (Denial of Service).
The vulnerability is caused due to an error in the processing of beacon frames. This can be exploited via a specially crafted beacon frame with an overly large &quot;length&quot; value (greater than 15) in the extended supported rates element (&quot;xrates&quot;).
Successful exploitation causes the driver to exit and results in a kernel panic.

Updated Packages
================

Check if you have madwifi installed:

	# pacman-g2 -Q madwifi

If found, then you should upgrade to the latest version:

	# pacman-g2 -Sy madwifi

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: See http://ftp.frugalware.org/pub/README.GPG for info

iD8DBQFHHaBvZ7NElSD1VhkRAq9iAJ0T9kP3+boR84qMW/WXU7qCoQML1wCgpj3q
3gSAOqVJ3zFkb7Np+eZ7eM8=
=P+fB
-----END PGP SIGNATURE-----


More information about the Frugalware-security mailing list