[Frugalware-security] [ FSA-448 ] php
vmiklos at frugalware.org
Tue May 20 13:22:22 CEST 2008
-----BEGIN PGP SIGNED MESSAGE-----
Frugalware Security Advisory FSA-448
Vulnerable versions: <= 5.2.5-2
Unaffected versions: >= 5.2.6-1kalgan1
Related bugreport: http://bugs.frugalware.org/task/3074
Some vulnerabilities have been reported in PHP, where some have unknown impacts and others can be exploited by malicious users to bypass certain security restrictions, and potentially by malicious people to cause a DoS (Denial of Service) or to compromise a vulnerable system.
1) An unspecified error in the FastCGI SAPI can be exploited to cause a stack-based buffer overflow.
2) An error in the processing of multibyte characters within the "escapeshellcmd()" and "escapeshellarg()" functions can be exploited to escape the inserted backslash or quote characters via certain multibyte characters.
Successful exploitation allows to bypass the "safe_mode_exec_dir" and "disable_functions" directives, and potentially to inject arbitrary shell commands via user controlled input, but requires that the shell uses a locale with a variable width character (e.g. GBK, EUC-KR, SJIS).
3) A vulnerability is caused due to an error during path translation in cgi_main.c. This can potentially be exploited to execute arbitrary code, but depends on how a targeted application is using PHP.
4) An error in cURL can be exploited to bypass the "safe_mode" directive.
5) A boundary error in PCRE can potentially be exploited by malicious people to cause a DoS or compromise a vulnerable system.
Check if you have php installed:
# pacman-g2 -Q php
If found, then you should upgrade to the latest version:
# pacman-g2 -Sy php
The latest revision of this advisory is available at
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: See http://ftp.frugalware.org/pub/README.GPG for info
-----END PGP SIGNATURE-----
More information about the Frugalware-security