Frugalware Let's make things frugal!
En Fr Es It
Package:postgresql
Date:2015-03-01
Posted by:kikadf
Vulnerable version:9.1.12-1
Unaffected version:9.1.15-1rigel2
Bug tracker entry:
CVEs:http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8161 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0241 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0243 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0244
Description:A user with limited clearance on a table might have access to information in columns without SELECT rights on through server error messages. The function to_char() might read/write past the end of a buffer. This might crash the server when a formatting template is processed. The pgcrypto module is vulnerable to stack buffer overrun that might crash the server. Emil Lenngren reported that an attacker can inject SQL commands when the synchronization between client and server is lost.