[Frugalware-bugs] #1060: Gaim refuses to start after update to 2.0.0beta3.1-1

Flyspray noreply at frugalware.org
Mon Aug 21 01:10:12 CEST 2006


THIS IS AN AUTOMATED MESSAGE, DO NOT REPLY.

A new Flyspray task has been opened.  Details are below.

User who did this - Josh Wheeler (deltalima)

Attached to Project - Packages
Summary - Gaim refuses to start after update to 2.0.0beta3.1-1
Task Type - Bug Report
Category - Applications
Status - Unconfirmed
Assigned To - 
Operating System - i686
Severity - Low
Priority - Normal
Reported Version - -current
Due in Version - 
Due Date - Undecided
Details - I updated to gaim 2.0.0beta3.1-1 this afternoon, and it now
absolutely refuses to start.

Running 'gaim -d' after clearing out ~/.gaim gives the following:
<code>plugins: probing /usr/lib/gaim/nautilus.so
plugins: /usr/lib/gaim/nautilus.so is unloadable: ABI version mismatch
1.5.x (need 2.0.x)
plugins: probing /usr/lib/gaim/perl.so
plugins: probing /usr/lib/gaim/notify.so
plugins: probing /usr/lib/gaim/gevolution.so
plugins: probing /usr/lib/gaim/spellchk.so
plugins: probing /usr/lib/gaim/libmsn.so
plugins: probing /usr/lib/gaim/relnot.so
plugins: probing /usr/lib/gaim/psychic.so
plugins: probing /usr/lib/gaim/ssl-nss.so
plugins: probing /usr/lib/gaim/libnovell.so
plugins: probing /usr/lib/gaim/ssl.so
plugins: probing /usr/lib/gaim/gaimrc.so
plugins: probing /usr/lib/gaim/ticker.so
plugins: probing /usr/lib/gaim/tcl.so
plugins: probing /usr/lib/gaim/statenotify.so
plugins: probing /usr/lib/gaim/gestures.so
plugins: probing /usr/lib/gaim/history.so
plugins: probing /usr/lib/gaim/libzephyr.so
plugins: probing /usr/lib/gaim/ssl-gnutls.so
plugins: probing /usr/lib/gaim/timestamp_format.so
plugins: probing /usr/lib/gaim/liboscar.so
plugins: probing /usr/lib/gaim/timestamp.so
plugins: probing /usr/lib/gaim/iconaway.so
plugins: probing /usr/lib/gaim/libsimple.so
plugins: probing /usr/lib/gaim/idle.so
plugins: probing /usr/lib/gaim/docklet.so
plugins: probing /usr/lib/gaim/libjabber.so
plugins: probing /usr/lib/gaim/libyahoo.so
plugins: probing /usr/lib/gaim/extplacement.so
plugins: probing /usr/lib/gaim/libirc.so
plugins: probing /usr/lib/gaim/encrypt.so
plugins: probing /usr/lib/gaim/libextprefs.so
plugins: /usr/lib/gaim/libextprefs.so is unloadable: ABI version
mismatch 1.5.x (need 2.0.x)
plugins: probing /usr/lib/gaim/libgaimperl.so
plugins: /usr/lib/gaim/libgaimperl.so is not usable because the
'gaim_init_plugin' symbol could not be found.  Does the plugin call
the GAIM_INIT_PLUGIN() macro?
util: Reading file accounts.xml from directory /home/deltalima/.gaim
util: File /home/deltalima/.gaim/accounts.xml does not exist (this is
not necessarily an error)
util: Reading file status.xml from directory /home/deltalima/.gaim
util: File /home/deltalima/.gaim/status.xml does not exist (this is
not necessarily an error)
stun: using server 
stun: using server 
sound: Initializing sound output drivers.
util: Reading file blist.xml from directory /home/deltalima/.gaim
util: File /home/deltalima/.gaim/blist.xml does not exist (this is not
necessarily an error)
prefs: Reading /home/deltalima/.gaim/prefs.xml
prefs: Reading /etc/gaim/gaim/prefs.xml
prefs: Error reading prefs: Failed to open file
'/etc/gaim/gaim/prefs.xml': No such file or directory
pounce: Error reading pounces: Failed to open file
'/home/deltalima/.gaim/pounces.xml': No such file or directory
Session Management: ICE initialized.
Session Management: Connecting with no previous ID
Session Management: Handling new ICE connection... done.
Session Management: Connected to manager (GnomeSM) with client ID
117f000001000115611175600000023870058
Session Management: Using gaim as command
prefs: /core/savedstatus/current changed, scheduling save.
Session Management: Received first save_yourself
Session Management: Received save_complete
gaim_url_fetch: requested to fetch
(http://192.168.1.1:80/Public_UPNP_gatedesc.xml), full=1,
user_agent=((null)), http11=1
dns: Created new DNS child 8058, there are now 1 children.
dns: Successfully sent DNS request to child 8058
dns: Got response for '192.168.1.1'
proxy: Connecting to 192.168.1.1:80 with no proxy
proxy: Connect would have blocked.
proxy: Connected.
gaim_url_fetch: Request: 'GET /Public_UPNP_gatedesc.xml HTTP/1.1
Connection: close
Host: 192.168.1.1:80

'
prefs: /gaim/gtk/blist/y changed, scheduling save.
gaim_url_fetch: Response headers: 'HTTP/1.1 200 OK
Server:Ambit OS/1.0 UPnP/1.0 AMBIT-UPNP/1.0
Connect:close
Content-length: 2660
Content-type: text/xml
Cache-Control:no-cache
Pragma:no-cache

'
g_log: xmlnode_get_child_with_namespace: assertion `parent != NULL'
failed
dns[8181]: Oops, father has gone, wait for me, wait...!</code>

This seems a bit odd to me since the xmlnode_get_child_with_namespace
function is pretty much just used for Jabber and to load your 'buddy
list', which shouldn't be happening at the point at which I'm getting
the error. And that 'Oops, father has gone, wait for me, wait...!"
error seems to come from proxy.c, and I shouldn't have any proxy
connections ever.

More information can be found at the following URL:
http://bugs.frugalware.org/task/1060

You are receiving this message because you have requested it from the
Flyspray bugtracking system.  You can be removed from future
notifications by visiting the URL shown above.



More information about the Frugalware-bugs mailing list