[Frugalware-bugs] #2151: pacman search doesn't work as expected

Frugalware noreply at frugalware.org
Sun Jun 10 18:32:48 CEST 2007


THIS IS AN AUTOMATED MESSAGE, DO NOT REPLY.

A new Flyspray task has been opened.  Details are below.

User who did this - Mike (mmiikkee12)

Attached to Project - Frugalware
Summary - pacman search doesn't work as expected
Task Type - Bug Report
Category - Base system
Status - Unconfirmed
Assigned To - 
Operating System - i686
Severity - Medium
Priority - Normal
Reported Version - -current
Due in Version - Undecided
Due Date - Undecided
Details - When I run:
[ mike in ~ ]$ sudo pacman -Ss gnome games
Pacman searches for all packages containing either 'gnome' or 'games'. One could call this a feature instead of a bug, but if I'm looking for the GNOME games package I probably didn't want kdegames, nor did I want xchat-gnome (well, I guess you could play a game of ASCII hangman over IRC, but that's not the point.) Also, since both 'gnome' and 'games' appear in gnome-games, it appears twice in the list (sudo pacman -Ss gnome games |grep gnome-games).

I also tried putting a search string with spaces in quotes (sudo pacman -Ss 'gnome games' or sudo pacman -Ss 'GNOME games'), but that finds no packages.


More information can be found at the following URL:
http://bugs.frugalware.org/?do=details&task_id=2151

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.


More information about the Frugalware-bugs mailing list