[Frugalware-darcs] frugalware-current: hk_classes-0.8.2-1-i686

crazy crazy at frugalware.org
Sat Oct 28 18:16:55 CEST 2006


Darcsweb-Url: http://darcs.frugalware.org/darcsweb/darcsweb.cgi?r=frugalware-current;a=darcs_commitdiff;h=20061028161259-f6986-0d5633425d66b1eedac3016fdf01c4a46c37a027.gz;

[hk_classes-0.8.2-1-i686
crazy <crazy at frugalware.org>**20061028161259
 * Version bump
 * added paradox subpkg
 * reworked FB
] {
hunk ./source/lib-extra/hk_classes/FrugalBuild 6
-pkgver=0.8.1
-pkgrel=2
+pkgver=0.8.2
+pkgrel=1
hunk ./source/lib-extra/hk_classes/FrugalBuild 13
-sha1sums=('04412bf30988d5f66f91c4bb86b9d285db493f8c')
hunk ./source/lib-extra/hk_classes/FrugalBuild 16
-makedepends=('mdbtools' 'mysql' 'unixodbc' 'postgresql' 'sqlite3')
+makedepends=('mdbtools' 'mysql' 'unixodbc' 'postgresql' 'sqlite3' 'pxlib')
hunk ./source/lib-extra/hk_classes/FrugalBuild 19
+options=('scriptlet')
+sha1sums=('9617f55dda428242a1218cf0c1499762af319d7d')
hunk ./source/lib-extra/hk_classes/FrugalBuild 22
-subpkgs=("$pkgname-mdb" "$pkgname-mysql" "$pkgname-odbc" "$pkgname-postgresql" \
-         "$pkgname-sqlite3")
-subdescs=("MS Access driver for Knoda." "MySQL driver for Knoda" \
-          "ODBC driver for Knoda" "PostgreSQL driver for Knoda" \
-	  "SQLite3 driver for Knoda")
-sublicense=("LGPL2" "LGPL2" "LGPL2" "LGPL2" "LGPL2")
-subgroups=("gnome-extra" "lib-extra" "lib-extra" "lib-extra" "lib-extra")
-subdepends=(" " " " " " " " " ")
-subrodepends=("$pkgname mdbtools" "$pkgname mysql" "$pkgname unixodbc" \
-              "$pkgname postgresql" "$pkgname sqlite3")
-subprovides=("$pkgname-driver" "$pkgname-driver" "$pkgname-driver" \
-             "$pkgname-driver" "$pkgname-driver")
-subarchs=('i686 x86_64' 'i686 x86_64' 'i686 x86_64' 'i686 x86_64' 'i686 x86_64')
+subpkgs=("$pkgname-mdb" "$pkgname-mysql" "$pkgname-odbc" "$pkgname-postgresql" "$pkgname-sqlite3" "$pkgname-paradox")
+subdescs=("MS Access driver for Knoda." "MySQL driver for Knoda" "ODBC driver for Knoda" "PostgreSQL driver for Knoda" \
+	  "SQLite3 driver for Knoda" "Paradox driver for Knoda")
+subgroups=("gnome-extra" "lib-extra" "lib-extra" "lib-extra" "lib-extra" "lib-extra")
+subdepends=("$pkgname=$pkgver mdbtools" "$pkgname=$pkgver mysql" "$pkgname=$pkgver unixodbc" \
+		"$pkgname=$pkgver postgresql" "$pkgname=$pkgver sqlite3" "$pkgname=$pkgver pxlib")
+subprovides=("$pkgname-driver" "$pkgname-driver" "$pkgname-driver" "$pkgname-driver" "$pkgname-driver" "$pkgname-driver")
+subarchs=('i686 x86_64' 'i686 x86_64' 'i686 x86_64' 'i686 x86_64' 'i686 x86_64' 'i686 x86_64')
hunk ./source/lib-extra/hk_classes/FrugalBuild 33
-	Fbuild --without-firebird --with-mdb --with-mysql --with-odbc \
-	       --without-paradox --with-postgres --without-sqlite --with-sqlite3
+	Fbuild  --without-firebird --with-mdb \
+		--with-mysql --with-odbc \
+		--with-paradox --with-postgres \
+		--without-sqlite --with-sqlite3
hunk ./source/lib-extra/hk_classes/FrugalBuild 48
+	Fsplit $pkgname-paradox usr/lib/$pkgname/drivers/libhk_paradoxdriver.* 
hunk ./source/lib-extra/hk_classes/FrugalBuild 51
-# vim: ft=sh
-
}


More information about the Frugalware-darcs mailing list