[Frugalware-darcs] gfpm: show update icon even if an installed package needs update.

Priyank priyank at frugalware.org
Wed Jul 4 08:37:27 CEST 2007


Darcsweb-Url: http://darcs.frugalware.org/darcsweb/darcsweb.cgi?r=gfpm;a=darcs_commitdiff;h=20070704063611-5ce2c-129d91fb584557a5f2cc94632cf786fccdf7c949.gz;

[show update icon even if an installed package needs update.
Priyank <priyank at frugalware.org>**20070704063611] {
hunk ./src/gfpm-interface.c 303
+			gboolean up = FALSE;
hunk ./src/gfpm-interface.c 306
+			if (!strcmp((char*)pacman_pkg_getinfo(pm_pkg,PM_PKG_VERSION),
+				(char*)pacman_pkg_getinfo(pm_lpkg,PM_PKG_VERSION)))
+				up = FALSE;
+			else
+				up = TRUE;
hunk ./src/gfpm-interface.c 313
-						1, icon_yes,
+						1, (up==TRUE)?icon_up:icon_yes,
}


More information about the Frugalware-darcs mailing list