[Frugalware-darcs] frugalware-current: libgpod-0.5.2-1-i686

crazy crazy at frugalware.org
Tue Jun 26 17:37:18 CEST 2007


Darcsweb-Url: http://darcs.frugalware.org/darcsweb/darcsweb.cgi?r=frugalware-current;a=darcs_commitdiff;h=20070626153605-f6986-3ef1fb36d68c0cdcb8fd0fdeb946a6d507bae659.gz;

[libgpod-0.5.2-1-i686
crazy <crazy at frugalware.org>**20070626153605
 * Version bump
 * err that package should work now 
] {
hunk ./source/xlib/libgpod/FrugalBuild 5
-pkgver=0.4.2
+pkgver=0.5.2
hunk ./source/xlib/libgpod/FrugalBuild 9
-Finclude python sourceforge
+Finclude sourceforge
hunk ./source/xlib/libgpod/FrugalBuild 12
-	'dbus-glib>=0.71' 'python>=2.5' 'taglib')
+	'dbus-glib>=0.71' 'python>=2.5' 'taglib' 'mutagen')
hunk ./source/xlib/libgpod/FrugalBuild 16
+up2date="lynx -dump 'http://sourceforge.net/project/showfiles.php?group_id=67873' | grep -v gtkpod- |grep -om1 'libgpod-\(.*\).tar.gz$'|Flasttar"
hunk ./source/xlib/libgpod/FrugalBuild 18
-up2date="lynx -dump http://sourceforge.net/project/showfiles.php?group_id=67873 |grep -m1 libgpod-[0-9] |sed 's/.*pod-//g'|sed 's/ .*//g'"
-
-build()
-{
-	Fbuild
-	Fmkdir $_F_python_libdir/gpod/examples
-	cd bindings/python
-	Fsed "python2.3" "$_F_python_ver" Makefile
-	Fsed "/mnt/ipod/" "/media/ipod" examples/play_with_smart_playlists.py
-	make || Fdie
-	Finstall 0644 $pkgname-$pkgver/bindings/python/gtkpod.py $_F_python_libdir/gtkpod.py
-	cp examples/* $Fdestdir/$_F_python_libdir/gpod/examples || Fdie
-}
+sha1sums=('fc9b26868710dcb24e758d7bd2bc52ee8532e16c')
hunk ./source/xlib/libgpod/FrugalBuild 21
-sha1sums=('b2aece62a206a5b703c50e6625b173217f1d67a6')
}


More information about the Frugalware-darcs mailing list