[Frugalware-git] kde5: qt5-webkit-5.9.0-1-x86_64 * Version bump * remove unused patch

crazy crazy at frugalware.org
Thu Jun 1 01:34:10 CEST 2017


Git-Url: http://git.frugalware.org/gitweb/gitweb.cgi?p=kde5.git;a=commitdiff;h=331129bfaa256cbfb6c6abe1b2f910ded43aecc4

commit 331129bfaa256cbfb6c6abe1b2f910ded43aecc4
Author: crazy <crazy at frugalware.org>
Date:   Thu Jun 1 01:33:36 2017 +0200

qt5-webkit-5.9.0-1-x86_64
* Version bump
* remove unused patch

diff --git a/source/xlib/qt5-webkit/FrugalBuild b/source/xlib/qt5-webkit/FrugalBuild
index fd6775d..e656cee 100644
--- a/source/xlib/qt5-webkit/FrugalBuild
+++ b/source/xlib/qt5-webkit/FrugalBuild
@@ -1,16 +1,16 @@
# Compiling Time: 64.56 SBU
-# Maintainer: Marius Cirsta <mcirsta at frugalware.org>
+# Maintainer: crazy <crazy at frugalware.org>

pkgname=qt5-webkit
-pkgver=5.7.1
-pkgrel=3
-depends=('qt5-declarative>=5.7.1-3' 'libwebp>=0.6.0' 'libxcomposite>=0.4.4-3' 'qt5-multimedia>=5.7.1-3' 'libxslt')
+pkgver=5.9.0
+pkgrel=1
+depends=("qt5-declarative>=$pkgver" 'libwebp>=0.6.0' 'libxcomposite>=0.4.4-3' "qt5-multimedia>=$pkgver" 'libxslt')
makedepends+=('ruby' 'x11-protos')
Finclude qt5
replaces=('libqt5webkit')
conflicts=("${replaces[@]}")
provides=("${replaces[@]}")
-source=("http://download.qt.io/community_releases/${pkgver%.*}/${pkgver}/qtwebkit-opensource-src-${pkgver}.tar.xz")
-sha1sums=('cd44a529cf24cf6f9eda93ac88c7d65dc2de3359')
+source=("http://download.qt.io/community_releases/${pkgver%.*}/${pkgver}-final/qtwebkit-opensource-src-${pkgver}.tar.xz")
+sha1sums=('25d0cc8d75f4cf794645b4b8dfec479a4996e438')

# optimization OK
diff --git a/source/xlib/qt5-webkit/qt5-webkit-pthread.patch b/source/xlib/qt5-webkit/qt5-webkit-pthread.patch
deleted file mode 100644
index 53d5439..0000000
--- a/source/xlib/qt5-webkit/qt5-webkit-pthread.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 5f359baacdf92fabcece83f0a2b30f74c7c02a3c Mon Sep 17 00:00:00 2001
-From: Allan Sandfeld Jensen <allan.jensen at theqtcompany.com>
-Date: Mon, 22 Feb 2016 10:57:32 +0100
-Subject: [PATCH] Fix linking with libpthread
-
-WebKit use libpthread directly but is depending on other qt modules
-causing it to be linked against, which might break unless -lpthread
-is last. Instead just add it explicitly after the static libraries.
-
-Change-Id: I2b95cff2c96373f8dce6f95052c4fccbe1982b33
-Reviewed-by: Simon Hausmann <simon.hausmann at theqtcompany.com>
-(cherry picked from commit 5dd4bb67cfce812fd7686e43616e2069f354a7df)
-Reviewed-by: Allan Sandfeld Jensen <allan.jensen at theqtcompany.com>
----
- Tools/qmake/mkspecs/features/default_post.prf | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/Tools/qmake/mkspecs/features/default_post.prf b/Tools/qmake/mkspecs/features/default_post.prf
-index 67276b7..39bb3f7 100644
---- a/Tools/qmake/mkspecs/features/default_post.prf
-+++ b/Tools/qmake/mkspecs/features/default_post.prf
-@@ -201,6 +201,7 @@ needToLink() {
-         linkAgainstLibrary($$library, $$eval(WEBKIT.$${library_identifier}.root_source_dir))
-         LIBS += $$eval(WEBKIT.$${library_identifier}.dependent_libs)
-     }
-+    posix:!darwin: LIBS += -lpthread
- }
-
- creating_module {
---
-2.7.1
-


More information about the Frugalware-git mailing list